Arduino Nano/Mac OSX problems SOLVED!


  • Metal

    After much head scratching and frustration I’ve solved the issue with my Mac computer not recognizing the Arduino Nano that I got from the lighting workshop.
    The problem is the USB->Serial chipset on these boards, its not the standard FTDI chip, its a chinese made one and the drivers need to be installed SPECIFICALLY for this chip.

    http://www.wch.cn/download/CH341SER_MAC_ZIP.html

    Here is the link to the manufacturers webpage, it is chinese but I’ve verified that these drivers do work with my Mac Mini.
    just download the zip, open it and run the installer.
    Reboot your Mac and plug in the Arduino, you should get a network setup dialog window, just hit apply (leave everything blank or automatic)
    my Nano now shows up in the Arduino IDE as /dev/tty.wchusbserial1d10



  • Thank you for solving the mystery! I will send out an email to all the participants tonight and will refer them to this post so that they can also use their mac. I did not anticipate this to be so tricky, lesson learned!


Log in to reply