help with uno boards, Autymn from skeetchestn school



  • hello I am having trouble with getting the lights to light up. everything is plugged in as explained by my teacher but I cannot get a strand test to work it keeps giving a error message while uploading



  • What is the error message?


  • Classroom

    @BlakeWolter, make sure that the the correct board is selected in Arduino under Tools>Board (should be Arduino Pro or Pro Mini for the Illuminame box). If you got a strand of lights from @Ron_Ron, then you will probably have to select Tools>Board>Arduino/Genuino UNO.

    Just under that setting, still in tools you will find port, make sure the correct port is selected (should be the port that isn’t there until the Arduino is plugged in - if one doesn’t appear when you plug in the USB that could indicated an issue as well). You will have to click out of tools, plug device in and go to tools again to check this.

    If all that looks good then make sure your lights are pinned correctly (usually Green to 6, Red to 5V and White to Neg I think) , and that the harness with the pins connected to it is attached to the correct end of the LED strand (the strand will have little arrows, I think these point away from the pins and to the end of the strand that isn’t connected to anything, but maybe try both to be safe).

    There are a few things that you can try, hopefully @Ron_Ron or others will comment if I am spreading any misinformation here.



  • you might need to down load a driver. CH340g

    I did a quick google search for issues with ch34og chip set.
    “I think I just discovered the answer to my own problem based on your feedback. While digging up the information for my response to your questions, I discovered the specific com port that Windows had assigned to the Arduino (USB-SERIAL CH340 (COM11)). I selected that specific Com port in the Arduino program…and behold, it connected and is working just fine!”
    Have you tried all the usb ports?



  • What does the error message say? you can scroll all the way to the top of the message, and that does the last part of the message say?



  • Hi Ron,

    We did the driver update and the error message has stopped when we hit upload.

    Lights still not lighting up. Anything we are missing?



  • Hello - Blake here.

    So my student installed the new CH340 Driver and tried all the different coms and also all the ports. No luck so far - but we are no longer getting an error message upon upload.

    Anything I can do to better explain this problem? Should I send in screen caps and pictures of the board?


  • Classroom

    @BlakeWolter, did you check the things that I mentioned in the post above? Specifically if the harness attaching the pins to the strip is on the strip on the wrong side, it would act just like this. Check that the little white arrows near the three copper ovals that appear along the strip all point away from the harness.

    Also you could try moving the pins around (i.e. from one GND spot to another GND spot for white). Sometimes a bad contact could cause an issue like that.

    With no error, it appears the arduino thinks it is programming correctly, so I would focus troubleshooting on the strand and its connections at this point. Am I correct that you have two strips and two arduinos? Have you tried both strips and both arduinos?



  • Yes I might have soldered the pins on the wrong side. I was so tired that long day. So try the other end of the led strip connected to arduino.


  • Design Lab

    Lets keep at this - if a return visit is required to make the gack function properly, no problem, no charge. Sorry for the technical difficulties, @BlakeWolter , new program!



  • I am glad to hear its all working well.


Log in to reply